<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head itemscope itemtype="http://schema.org/WebSite">
	<meta charset="UTF-8">
	<!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame -->
	<!--[if IE ]>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<![endif]-->
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<!--iOS/android/handheld specific -->
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-status-bar-style" content="black">
    <meta itemprop="name" content="Minneapolis Globe" />
    <meta itemprop="url" content="http://www.minneapolisglobe.com" />
        <meta itemprop="creator accountablePerson" content=" " />
    	<link rel="pingback" href="http://www.minneapolisglobe.com/xmlrpc.php" />
	<title>Working For The Weekend: Entertainment Best Bets | Minneapolis Globe</title>
<script type="text/javascript">document.documentElement.className = document.documentElement.className.replace( /\bno-js\b/,'js' );</script><link rel="alternate" type="application/rss+xml" title="Minneapolis Globe &raquo; Feed" href="http://www.minneapolisglobe.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Minneapolis Globe &raquo; Comments Feed" href="http://www.minneapolisglobe.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Minneapolis Globe &raquo; Working For The Weekend: Entertainment Best Bets Comments Feed" href="http://www.minneapolisglobe.com/working-for-the-weekend-entertainment-best-bets-16/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"http:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.minneapolisglobe.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.2.15"}};
			!function(a,b,c){function d(a){var c=b.createElement("canvas"),d=c.getContext&&c.getContext("2d");return d&&d.fillText?(d.textBaseline="top",d.font="600 32px Arial","flag"===a?(d.fillText(String.fromCharCode(55356,56812,55356,56807),0,0),c.toDataURL().length>3e3):(d.fillText(String.fromCharCode(55357,56835),0,0),0!==d.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='stylesheet-css'  href='http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/style.css?ver=4.2.15' type='text/css' media='all' />
<style id='stylesheet-inline-css' type='text/css'>

        body {background-color:#ffffff;background-image:url(http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/images/nobg.png);}
        
        .pace .pace-progress, #mobile-menu-wrapper ul li a:hover, .post-info .thecategory { background: #0088cc; }
        .single_post a, .textwidget a, .pnavigation2 a, .sidebar.c-4-12 a:hover, .copyrights a:hover, footer .widget li a:hover, .sidebar.c-4-12 a:hover, .related-posts a:hover, .title a:hover, .post-info a:hover, .comm, #tabber .inside li a:hover, .readMore a:hover, .fn a, a, a:hover, .latestPost .title a:hover, .theme-color, a#pull, #navigation ul ul li:hover > a { color:#0088cc; }  
        #commentform .form-submit input#submit, .contactform #submit, #move-to-top, .pagination a, #tabber ul.tabs li a.selected, .tagcloud a, .tagcloud a:hover .tab_count, #navigation ul .sfHover a, .reply a, .widget .wpt_widget_content .tab_title a, .widget .wp_review_tab_widget_content .tab_title a, .widget #wp-subscribe, .contact-form input[type='submit'], #load-posts a, #load-posts a.disabled, .latestPost-review-wrapper, .latestPost .review-type-circle.review-total-only, .latestPost .review-type-circle.wp-review-show-total, .wpmm-thumbnail .review-total-only, .widget .review-total-only.small-thumb, .widget .wpt_widget_content #tags-tab-content ul li a { background-color:#0088cc; color: #fff!important; }
        .main-header, #header .head-search #s, .head-search .fa-search {background: #333; }
        footer {background: #333; }
        
        
        
         .bypostauthor .fn:after { content: "Author"; position: relative; padding: 1px 6px; margin-left: 5px; background: #333; color: #FFF; font-size: 12px; line-height: 18px; border-radius: 3px; }
        
        
        
    
</style>
<link rel='stylesheet' id='fontawesome-css'  href='http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/css/font-awesome.min.css?ver=4.2.15' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/css/responsive.css?ver=4.2.15' type='text/css' media='all' />
<script type='text/javascript' src='http://www.minneapolisglobe.com/wp-includes/js/jquery/jquery.js?ver=1.11.2'></script>
<script type='text/javascript' src='http://www.minneapolisglobe.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mts_customscript = {"responsive":"1","nav_menu":"secondary","home_pagenavigation":"1","ajax_url":"http:\/\/www.minneapolisglobe.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/js/customscript.js?ver=4.2.15'></script>
<script type='text/javascript' src='http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/js/waypoints.min.js?ver=4.2.15'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.minneapolisglobe.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.minneapolisglobe.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Vikings CB Terence Newman: ‘This Will Be It For Me’' href='http://www.minneapolisglobe.com/vikings-cb-terence-newman-this-will-be-it-for-me-2/' />
<link rel='next' title='After Ending 14-Year Playoff Drought, What’s Next For Timberwolves?' href='http://www.minneapolisglobe.com/after-ending-14-year-playoff-drought-whats-next-for-timberwolves-2/' />
<!--Theme by MyThemeShop.com-->
<link rel='canonical' href='http://www.minneapolisglobe.com/working-for-the-weekend-entertainment-best-bets-16/' />
<link rel='shortlink' href='http://www.minneapolisglobe.com/?p=5204' />
<link href="//fonts.googleapis.com/css?family=Roboto:500|Roboto:700|PT+Serif:normal&amp;subset=latin" rel="stylesheet" type="text/css">
<style type="text/css">
#header, .menu li, .menu li a, a#pull { font-family: 'Roboto'; font-weight: 500; font-size: 15px; color: #dddddd; }
.latestPost .title a, .reply a, .widget .post-title, .pagination, #load-posts, .popular-category a, .ajax-search-results li a { font-family: 'Roboto'; font-weight: 500; font-size: 24px; color: #333333; }
#tab-group a { font-family: 'Roboto'; font-weight: 700; font-size: 14px; color: #555555;text-transform: uppercase; }
.single-title { font-family: 'Roboto'; font-weight: 700; font-size: 42px; color: #333333; }
body { font-family: 'PT Serif'; font-weight: normal; font-size: 19px; color: #575757; }
#sidebars .widget { font-family: 'Roboto'; font-weight: 500; font-size: 15px; color: #575757; }
footer { font-family: 'Roboto'; font-weight: 500; font-size: 15px; color: #aaaaaa; }
.post-info, .category-head, .left-comment, .ago, #searchform #s, .tagcloud, .recommended-post, .breadcrumb, .latestPost-review-wrapper { font-family: 'Roboto'; font-weight: 500; font-size: 12px; color: #333333; }
h1, .write-for-us a, .fn, #commentform input#submit, .contact-form input[type="submit"] { font-family: 'Roboto'; font-weight: 700; font-size: 42px; color: #333333; }
h2 { font-family: 'Roboto'; font-weight: 700; font-size: 36px; color: #333333; }
h3 { font-family: 'Roboto'; font-weight: 700; font-size: 32px; color: #333333; }
h4 { font-family: 'Roboto'; font-weight: 700; font-size: 28px; color: #333333; }
h5 { font-family: 'Roboto'; font-weight: 700; font-size: 24px; color: #333333; }
h6 { font-family: 'Roboto'; font-weight: 700; font-size: 20px; color: #333333; }
</style>
</head>
<body id="blog" class="single single-post postid-5204 single-format-standard main" itemscope itemtype="http://schema.org/WebPage">       
			<div class="clear" id="catcher"></div>
		<div id="sticky" class="" role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
			<header class="main-header" role="banner" itemscope itemtype="http://schema.org/WPHeader">
			<div class="container">
				<div id="header">
					<div class="logo-wrap">
																					<h2 id="logo" class="image-logo" itemprop="headline">
									<a href="http://www.minneapolisglobe.com"><img src="http://www.minneapolisglobe.com/wp-content/uploads/2016/10/minneapolisglobe.png" alt="Minneapolis Globe"></a>
								</h2><!-- END #logo -->
																		</div>
					
							
						<div class="secondary-navigation" role="navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
							<a href="#" id="pull" class="toggle-mobile-menu">Menu</a>
							<nav id="navigation" class="clearfix mobile-menu-wrapper">
																	<ul id="menu-main" class="menu clearfix"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/news/">News</a></li>
<li id="menu-item-8" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/events/">Events</a></li>
<li id="menu-item-7" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-9" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/health/">Health</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://www.minneapolisglobe.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/sports/timberwolves/">Timberwolves</a></li>
	<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/sports/twins/">Twins</a></li>
	<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/sports/vikings/">Vikings</a></li>
	<li id="menu-item-17" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/sports/wild/">Wild</a></li>
</ul>
</li>
<li id="menu-item-18" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/technology/">Technology</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/nature/">Nature</a></li>
<li id="menu-item-19" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.minneapolisglobe.com/category/travel/">Travel</a></li>
<li id="menu-item-20" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="http://www.minneapolisglobe.com/category/videos/">Videos</a></li>
</ul>															</nav>
						</div>  
					  

											<div class="head-search">
							<i class="fa fa-search search-trigger"></i>
							<form method="get" id="searchform" class="search-form" action="http://www.minneapolisglobe.com" _lpchecked="1">
	<fieldset>
		<input type="text" name="s" id="s" value="" placeholder="Search the site"  />
		<input id="search-image" class="sbutton" type="submit" value="" />
		<i class="fa fa-search"></i>
	</fieldset>
</form>						</div>
										
											<div class="header-social-icon">   
							<ul>
																    
							</ul>
						</div>
					
				</div><!--#header-->
			</div><!--.container-->
		</header>				       
			</div>
			<div class="header-post-wrap">    
            <!-- Start Header Posts -->
        
                    <div class="header-posts"><div class="clear">                                <article class="header-post excerpt  ">
                                    <div class="header-post-img">
                                        <a href="http://www.minneapolisglobe.com/allina-health-nurse-allegedly-reused-syringes/" title="Allina Health Nurse Allegedly Reused Syringes" rel="nofollow" id="featured-thumbnail">
                                            <div class="featured-thumbnail"><img src="http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/images/nothumb-header.png" class="attachment-header wp-post-image" alt="Allina Health Nurse Allegedly Reused Syringes"></div>                                        </a>
                                    </div>
                                    <h2 class="title header-post-title"><a href="http://www.minneapolisglobe.com/allina-health-nurse-allegedly-reused-syringes/" title="Allina Health Nurse Allegedly Reused Syringes">Allina Health Nurse Allegedly Reused Syringes</a></h2>
                                </article><!--.post.excerpt-->
                                                            <article class="header-post excerpt  ">
                                    <div class="header-post-img">
                                        <a href="http://www.minneapolisglobe.com/tim-mcgraw-to-play-charity-concert-on-lake-minnetonka/" title="Tim McGraw To Play Charity Concert On Lake Minnetonka" rel="nofollow" id="featured-thumbnail">
                                            <div class="featured-thumbnail"><img src="http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/images/nothumb-header.png" class="attachment-header wp-post-image" alt="Tim McGraw To Play Charity Concert On Lake Minnetonka"></div>                                        </a>
                                    </div>
                                    <h2 class="title header-post-title"><a href="http://www.minneapolisglobe.com/tim-mcgraw-to-play-charity-concert-on-lake-minnetonka/" title="Tim McGraw To Play Charity Concert On Lake Minnetonka">Tim McGraw To Play Charity Concert On Lake Minnetonka</a></h2>
                                </article><!--.post.excerpt-->
                                                            <article class="header-post excerpt  ">
                                    <div class="header-post-img">
                                        <a href="http://www.minneapolisglobe.com/minneapolis-police-officer-arrested-for-criminal-sexual-conduct/" title="Minneapolis Police Officer Arrested For Criminal Sexual Conduct" rel="nofollow" id="featured-thumbnail">
                                            <div class="featured-thumbnail"><img src="http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/images/nothumb-header.png" class="attachment-header wp-post-image" alt="Minneapolis Police Officer Arrested For Criminal Sexual Conduct"></div>                                        </a>
                                    </div>
                                    <h2 class="title header-post-title"><a href="http://www.minneapolisglobe.com/minneapolis-police-officer-arrested-for-criminal-sexual-conduct/" title="Minneapolis Police Officer Arrested For Criminal Sexual Conduct">Minneapolis Police Officer Arrested For Criminal Sexual Conduct</a></h2>
                                </article><!--.post.excerpt-->
                                                            <article class="header-post excerpt  last">
                                    <div class="header-post-img">
                                        <a href="http://www.minneapolisglobe.com/teen-killed-in-inver-grove-heights-party-bus-shooting-2/" title="Teen Killed In Inver Grove Heights Party Bus Shooting" rel="nofollow" id="featured-thumbnail">
                                            <div class="featured-thumbnail"><img src="http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/images/nothumb-header.png" class="attachment-header wp-post-image" alt="Teen Killed In Inver Grove Heights Party Bus Shooting"></div>                                        </a>
                                    </div>
                                    <h2 class="title header-post-title"><a href="http://www.minneapolisglobe.com/teen-killed-in-inver-grove-heights-party-bus-shooting-2/" title="Teen Killed In Inver Grove Heights Party Bus Shooting">Teen Killed In Inver Grove Heights Party Bus Shooting</a></h2>
                                </article><!--.post.excerpt-->
                            </div></div>            <!-- .related-posts -->
        </div>
<div class="main-container">
	<div id="page" class="single clearfix">
		<article class="article" itemscope itemtype="http://schema.org/BlogPosting">
			<div id="content_box" >
									<div id="post-5204" class="g post post-5204 type-post status-publish format-standard hentry category-videos">
						
									<div class="single_post">
																						<div class="post-image post-image-left">
												    <div class="featured-thumbnail"><img src="http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/images/nothumb-featuredfull.png" class="attachment-featuredfull wp-post-image" alt="Working For The Weekend: Entertainment Best Bets"></div>												    												</div>
																					<div class="post-single-content-wrap">
											<div id="left-share">
												<div id="left-share-inner">
													<div class="left-comment"><span>no</span> comments</div>
													            <!-- Start Share Buttons -->
            <div class="shareit">
                                <!-- Facebook -->
                <span class="share-item facebookbtn">
                    <div id="fb-root"></div>
                    <div class="fb-like" data-send="false" data-layout="button_count" data-width="150" data-show-faces="false"></div>
                </span>
                            <!-- Facebook -->
                <span class="share-item facebooksharebtn">
                    <a href="//www.facebook.com/share.php?m2w&s=100&p[url]=http%3A%2F%2Fwww.minneapolisglobe.com%2Fworking-for-the-weekend-entertainment-best-bets-16%2F&p[images][0]=&p[title]=Working For The Weekend: Entertainment Best Bets" class="single-social"><i class="fa fa-facebook"></i> Share</a>

                </span>
                            <!-- Twitter -->
                <span class="share-item twitterbutton">
                     
                    <a href="https://twitter.com/intent/tweet?original_referer=http%3A%2F%2Fwww.minneapolisglobe.com%2Fworking-for-the-weekend-entertainment-best-bets-16%2F&text=Working For The Weekend: Entertainment Best Bets&url=http%3A%2F%2Fwww.minneapolisglobe.com%2Fworking-for-the-weekend-entertainment-best-bets-16%2F" class="single-social"><i class="fa fa-twitter"></i> Tweet</a>
                </span>
                            <!-- GPlus -->
                <span class="share-item gplusbtn">
                    <!-- <g:plusone size="medium"></g:plusone> -->
                    <a href="//plus.google.com/share?url=http%3A%2F%2Fwww.minneapolisglobe.com%2Fworking-for-the-weekend-entertainment-best-bets-16%2F" class="single-social"><i class="fa fa-google-plus"></i> Share</a>
                </span>
                            <!-- Pinterest -->
                <span class="share-item pinbtn">
                    <a href="//pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.minneapolisglobe.com%2Fworking-for-the-weekend-entertainment-best-bets-16%2F + '&media=&description=Working For The Weekend: Entertainment Best Bets" class="single-social"><i class="fa fa-pinterest-p"></i> Pin it</a>

                </span>
                            <!--Linkedin -->
                <span class="share-item linkedinbtn">                 
                    <a href="//www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.minneapolisglobe.com%2Fworking-for-the-weekend-entertainment-best-bets-16%2F&title=Working For The Weekend: Entertainment Best Bets&source=url" class="single-social"><i class="fa fa-linkedin"></i> Share</a>
                </span>
                            <!-- Stumble -->
                <span class="share-item stumblebtn">                
                    <a href="http://www.stumbleupon.com/submit?url=http%3A%2F%2Fwww.minneapolisglobe.com%2Fworking-for-the-weekend-entertainment-best-bets-16%2F&title=Working For The Weekend: Entertainment Best Bets" class="single-social"><i class="fa fa-stumbleupon"></i> Stumble</a>
                </span>
                            <!-- Email -->
                <span class="share-item emailbtn">                
                    <a href="mailto:?Subject=Working For The Weekend: Entertainment Best Bets&Body=I%20saw%20this%20and%20thought%20of%20you!%20 http%3A%2F%2Fwww.minneapolisglobe.com%2Fworking-for-the-weekend-entertainment-best-bets-16%2F" class="single-social"><i class="fa fa-envelope"></i> Email</a>
                </span>
                        </div>
            <!-- end Share Buttons -->
        												</div>
											</div>
											<div class="post-single-content box mark-links entry-content">
																								<div class="breadcrumb" xmlns:v="http://rdf.data-vocabulary.org/#"><div typeof="v:Breadcrumb" class="root"><a rel="v:url" property="v:title" href="http://www.minneapolisglobe.com" rel="nofollow">Home</a></div><div class="breadcrumb-icon"><i class="fa fa-angle-double-right"></i></div><div typeof="v:Breadcrumb"><a href="http://www.minneapolisglobe.com/category/videos/" rel="v:url" property="v:title">Videos</a></div><div class="breadcrumb-icon"><i class="fa fa-angle-double-right"></i></div><div typeof='v:Breadcrumb'><span property='v:title'>Working For The Weekend: Entertainment Best Bets</span></div></div>
																								<header>
													<h1 class="title single-title entry-title" itemprop="headline">Working For The Weekend: Entertainment Best Bets</h1>
													            <div class="post-info">
                                <span class="thecategory"  style="background: ;"><a href="http://www.minneapolisglobe.com/category/videos/" title="View all posts in Videos">Videos</a></span>
                        </div>
        												</header><!--.headline_area-->
																								<div class="thecontent" itemprop="articleBody">
													<p><a href="http://minnesota.cbslocal.com/2018/05/03/working-for-the-weekend-best-bets/">Working For The Weekend: Entertainment Best Bets</a><br/><br />
<section class="column-item media-type-ndn  close-btn" id="featured-media" readability="-49">
<div class="cbs-thumbnail-link" readability="7">
<div class="thumbnail-wrapper"><span class="balance"><img src="https://cbsminnesota.files.wordpress.com/2013/05/canterbury-park-2.jpg?w=1024&amp;h=576&amp;crop=1"></span></div>
<p><em class="description">(credit: Canterbury Park/Facebook)</em></p>
</div>
</section>
<div class="main-story-wrapper" readability="57.349242424242">
<p><strong>MINNEAPOLIS (WCCO) —</strong>&nbsp;It’s a busy weekend in the Twin Cities. There are a ton of events to celebrate the Kentucky Derby, Cinco de Mayo and May Day. WCCO This Morning highlighted a couple of them if you are Working for the Weekend.</p>
<p><strong><a href="http://www.canterburypark.com/" target="_blank" rel="noopener">Canterbury Park Opens</a></strong></p>
<p>Celebrate the Kentucky Derby this weekend by watching live horse racing in Shakopee.&nbsp;Canterbury Park officially opens for the season Friday.&nbsp;Last year, a crowd of more than 20,000 attended the races on the first Saturday in May.</p>
<p><strong><a href="http://www.festivalofnations.com/" target="_blank" rel="noopener">Festival Of Nations</a></strong></p>
<p>Festival of Nations returns to Saint Paul RiverCentre. Celebrate an array of cultures through exhibits, music and dance, and food.&nbsp;The Festival of Nations takes place Thursday through Sunday.</p>
<p><strong><a href="http://www.cincodemayosaintpaul.com" target="_blank" rel="noopener">Cinco De Mayo In St. Paul</a></strong></p>
<p>Saturday is Cinco De Mayo and that means a big celebration in St. Paul’s West Side.&nbsp;Head to Cesar Chavez street in St. Paul for a day filled with cultural entertainment, excitement and exploring all the Westside has to offer.</p>
<p><strong><a href="http://hobt.org/mayday" target="_blank" rel="noopener">May Day Parade</a></strong></p>
<p>Finally, how about a parade in Minneapolis’ Powderhorn Park? The May Day Parade is a time to celebrate the warm weather with hand-built puppets and masks (some over 10 feet tall), music, dancing and performance in the street. The parade is Sunday at noon beginning at the corner of 25th St. E. and Bloomington Ave. S. and ends with a festival at the park.</p>
</div>
<p><strong><a href="https://blockads.fivefilters.org">Let&#8217;s block ads!</a></strong> <a href="https://blockads.fivefilters.org/acceptable.html">(Why?)</a></p>
<p><br/>Published at Thu, 03 May 2018 10:00:36 +0000</p>

                <script type="text/javascript">
                jQuery(document).ready(function($) {
                    $.post('http://www.minneapolisglobe.com/wp-admin/admin-ajax.php', {action: 'mts_view_count', id: '5204'});
                });
                </script>												</div>
																																				<!--Recommended for you -->
												    
            <!-- Start Recommended Posts -->
            <div class="recommended-posts"><div class="clear">                <article class="recommended-post">
                    <div class="recommended-post-img">
                        <a href="http://www.minneapolisglobe.com/wild-drop-2nd-straight-game-4-1-to-chicago-2/" title="Wild Drop 2nd Straight Game 4-1 To Chicago" rel="nofollow" id="featured-thumbnail">
                            <div class="featured-thumbnail"><img src="http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/images/nothumb-featured.png" class="attachment-featured wp-post-image" alt="Wild Drop 2nd Straight Game 4-1 To Chicago"></div>                                                    </a>
                    </div>
                    <header>
                        <h4 class="recommended">Recommended For You</h4>                        <h2 class="title recommended-title"><a href="http://www.minneapolisglobe.com/wild-drop-2nd-straight-game-4-1-to-chicago-2/" title="Wild Drop 2nd Straight Game 4-1 To Chicago">Wild Drop 2nd Straight Game 4-1 To Chicago</a></h2>
                        <p><a rel="nofollow" href="http://www.minneapolisglobe.com/author/mnglobe/" title="Posts by mnglobe" rel="author">mnglobe</a></p>
                    </header>
                </article><!--.post.excerpt-->
                </div></div>            <!-- .related-posts -->
        												
												<!--Author Box -->
																							</div><!--.post-single-content-->
										</div><!--.post-single-content-wrap-->
									</div><!--.single_post-->
																		<div class="related-wrap">
										<div class="related-left">
											    
            <!-- Start Related Posts -->
            <div class="related-posts"><h4>Related Posts</h4><div class="clear">                <article class="latestPost excerpt  ">
                    <a href="http://www.minneapolisglobe.com/100-crashes-spinouts-statewide-after-overnight-snow/" title="100+ Crashes &amp; Spinouts Statewide After Overnight Snow" rel="nofollow" id="featured-thumbnail">
                        <div class="featured-thumbnail"></div>                                            </a>
                    <header>
                        <h2 class="title front-view-title"><a href="http://www.minneapolisglobe.com/100-crashes-spinouts-statewide-after-overnight-snow/" title="100+ Crashes &amp; Spinouts Statewide After Overnight Snow">100+ Crashes &amp; Spinouts Statewide After Overnight Snow</a></h2>
                        <div class="post-info"><a rel="nofollow" href="http://www.minneapolisglobe.com/author/mnglobe/" title="Posts by mnglobe" rel="author">mnglobe</a></div>
                    </header>
                </article><!--.post.excerpt-->
                                <article class="latestPost excerpt  last">
                    <a href="http://www.minneapolisglobe.com/space-heater-suspected-in-isanti-co-house-fire/" title="Space Heater Suspected In Isanti Co. House Fire" rel="nofollow" id="featured-thumbnail">
                        <div class="featured-thumbnail"></div>                                            </a>
                    <header>
                        <h2 class="title front-view-title"><a href="http://www.minneapolisglobe.com/space-heater-suspected-in-isanti-co-house-fire/" title="Space Heater Suspected In Isanti Co. House Fire">Space Heater Suspected In Isanti Co. House Fire</a></h2>
                        <div class="post-info"><a rel="nofollow" href="http://www.minneapolisglobe.com/author/mnglobe/" title="Posts by mnglobe" rel="author">mnglobe</a></div>
                    </header>
                </article><!--.post.excerpt-->
                </div></div>            <!-- .related-posts -->
        										</div>
										<div class="related-ads">
																					</div>
									</div>
													</div><!--.g post-->
					<!-- You can start editing here. -->
<!-- If comments are closed. -->
<p class="nocomments"></p>

							</div>
		</article>
		<aside class="sidebar c-4-12 clearfix" role="complementary" itemscope itemtype="http://schema.org/WPSideBar">
	<div id="sidebars" class="g">
		<div class="sidebar">
					<div id="recent-posts-2" class="widget widget_recent_entries">		<h3 class="widget-title">Recent</h3>		<ul>
					<li>
				<a href="http://www.minneapolisglobe.com/amazon-unveils-north-loop-tech-hub-adds-200-jobs-3/">Amazon Unveils North Loop Tech Hub, Adds 200 Jobs</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/sheriff-man-22-dies-after-truck-crashes-into-northern-minnesota-reservoir/">Sheriff: Man, 22, Dies After Truck Crashes Into Northern Minnesota Reservoir</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/chuck-fletcher-out-as-wild-general-manager-15/">Chuck Fletcher Out As Wild General Manager</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/farmers-market-back-on-nicollet-mall/">Farmers Market Back On Nicollet Mall</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/after-ending-14-year-playoff-drought-whats-next-for-timberwolves-2/">After Ending 14-Year Playoff Drought, What’s Next For Timberwolves?</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/working-for-the-weekend-entertainment-best-bets-16/">Working For The Weekend: Entertainment Best Bets</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/vikings-cb-terence-newman-this-will-be-it-for-me-2/">Vikings CB Terence Newman: ‘This Will Be It For Me’</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/amazon-unveils-north-loop-tech-hub-adds-200-jobs-2/">Amazon Unveils North Loop Tech Hub, Adds 200 Jobs</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/mpls-singer-jovonta-patton-is-back-atop-the-gospel-charts-27/">Mpls. Singer Jovonta Patton Is Back Atop The Gospel Charts</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/romero-wins-mlb-debut-twins-beat-blue-jays-4-0/">Romero Wins MLB Debut, Twins Beat Blue Jays 4-0</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/what-do-migrants-need-to-gain-asylum/">What Do Migrants Need To Gain Asylum?</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/amazon-unveils-north-loop-tech-hub-adds-200-jobs/">Amazon Unveils North Loop Tech Hub, Adds 200 Jobs</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/chuck-fletcher-out-as-wild-general-manager-14/">Chuck Fletcher Out As Wild General Manager</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/report-midwest-business-conditions-index-rose-again-3/">Report: Midwest Business Conditions Index Rose Again</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/st-paul-police-k9-makes-special-visit-to-childrens-hospital/">St. Paul Police K9 Makes Special Visit To Children’s Hospital</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/vikings-cb-terence-newman-this-will-be-it-for-me/">Vikings CB Terence Newman: ‘This Will Be It For Me’</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/why-do-our-dogs-act-the-way-they-do-2/">Why Do Our Dogs Act The Way They Do?</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/report-midwest-business-conditions-index-rose-again-2/">Report: Midwest Business Conditions Index Rose Again</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/infinity-war-surges-past-star-wars-with-record-250-million-opening-weekend-2/">‘Infinity War’ Surges Past ‘Star Wars’ With Record $250 Million Opening Weekend</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/chuck-fletcher-out-as-wild-general-manager-13/">Chuck Fletcher Out As Wild General Manager</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/why-do-our-dogs-act-the-way-they-do/">Why Do Our Dogs Act The Way They Do?</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/report-midwest-business-conditions-index-rose-again/">Report: Midwest Business Conditions Index Rose Again</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/cambridge-man-accused-of-stealing-teens-hockey-bag/">Cambridge Man Accused Of Stealing Teen’s Hockey Bag</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/vikings-re-sign-cb-terence-newman/">Vikings Re-Sign CB Terence Newman</a>
						</li>
					<li>
				<a href="http://www.minneapolisglobe.com/chuck-fletcher-out-as-wild-general-manager-12/">Chuck Fletcher Out As Wild General Manager</a>
						</li>
				</ul>
		</div><div id="categories-2" class="widget widget_categories"><h3 class="widget-title">Categories</h3>		<ul>
	<li class="cat-item cat-item-16"><a href="http://www.minneapolisglobe.com/category/business/" >Business</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://www.minneapolisglobe.com/category/entertainment/" >Entertainment</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://www.minneapolisglobe.com/category/events/" >Events</a>
</li>
	<li class="cat-item cat-item-12"><a href="http://www.minneapolisglobe.com/category/health/" >Health</a>
</li>
	<li class="cat-item cat-item-13"><a href="http://www.minneapolisglobe.com/category/nature/" >Nature</a>
</li>
	<li class="cat-item cat-item-4"><a href="http://www.minneapolisglobe.com/category/news/" >News</a>
</li>
	<li class="cat-item cat-item-2"><a href="http://www.minneapolisglobe.com/category/technology/" >Technology</a>
</li>
	<li class="cat-item cat-item-8"><a href="http://www.minneapolisglobe.com/category/sports/timberwolves/" >Timberwolves</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://www.minneapolisglobe.com/category/travel/" >Travel</a>
</li>
	<li class="cat-item cat-item-9"><a href="http://www.minneapolisglobe.com/category/sports/twins/" >Twins</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://www.minneapolisglobe.com/category/videos/" >Videos</a>
</li>
	<li class="cat-item cat-item-7"><a href="http://www.minneapolisglobe.com/category/sports/vikings/" >Vikings</a>
</li>
	<li class="cat-item cat-item-10"><a href="http://www.minneapolisglobe.com/category/sports/wild/" >Wild</a>
</li>
		</ul>
</div><div id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-pages-container"><ul id="menu-pages" class="menu"><li id="menu-item-97" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-97"><a href="http://www.minneapolisglobe.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-98" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98"><a href="http://www.minneapolisglobe.com/contact-us/">Contact Us</a></li>
</ul></div></div>		</div>
	</div><!--sidebars-->
</aside>
		</div><!--#page-->
</div><!--.main-container-->
<footer class="footer" role="contentinfo" itemscope itemtype="http://schema.org/WPFooter">
	<div class="container">
        
              
       
        
        <div class="copyrights footer-disable">
                            <div class="footer-social">
                    <a href="#" style="background:#6686b7"><i class="fa fa-facebook"></i></a><a href="#" style="background:#54c1de"><i class="fa fa-twitter"></i></a><a href="#" style="background:#e55e4c"><i class="fa fa-google-plus"></i></a><a href="#" style="background:#476b89"><i class="fa fa-tumblr"></i></a><a href="#" style="background:#ff5e63"><i class="fa fa-pinterest"></i></a><a href="#" style="background:#fcba55"><i class="fa fa-rss"></i></a>                </div>
            			<!--start copyrights-->
<div class="row" id="copyright-note">
<span><a href="http://www.minneapolisglobe.com/" title="Mineapolis, Minesotta News" rel="nofollow">Minneapolis Globe</a> Copyright &copy; 2018.</span>
<div class="to-top"></div>
</div>
<!--end copyrights-->
		</div> 
	</div><!--.container-->
</footer><!--footer-->
<script type='text/javascript' src='http://www.minneapolisglobe.com/wp-content/themes/mts_newspaper/js/sticky.js?ver=4.2.15'></script>
</body>
</html>